activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bodhayan Chakraborty <bodhay...@gmail.com>
Subject disable audit still shows duplicate detection
Date Wed, 28 Nov 2012 18:53:41 GMT
Hi,

I am using a network of brokers. In my case, the number of consumers are
less than the number of brokers. So, for some brokers, there are no
consumers. Previously, in version 5.5.0, we had to stop some of the brokers
just to avoid message piling up in those brokers where there is no
consumers. Thanks to "replayWhenNoConsumers" property in version 5.6.0+, I
see that messages are not piling up in that broker which does not have any
consumer. As suggested in the blog
http://tmielke.blogspot.com/2012/03/i-have-messages-on-queue-but-they-dont.html,
I also disabled duplicate detection by setting enableAudit to "false". But
still I see pending message (though number of them are less) in the brokers.
And as it is said in the above blog, when I browse the queue, I don't see
any message. I see this in the log of the brokers. "Duplicate message add
attempt rejected. Destination: <queue_name>". Do I need to configure
anything else? PFA my  activemq.xml
<http://activemq.2283324.n4.nabble.com/file/n4659900/activemq.xml>   file.

Any help will be highly appreciated.

Thanks,
Bodhayan.



--
View this message in context: http://activemq.2283324.n4.nabble.com/disable-audit-still-shows-duplicate-detection-tp4659900.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message