activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mk <mkarmow...@mikronika.com.pl>
Subject Re: ActiveMQ-CPP with IBM WebSphere MQ
Date Fri, 23 Nov 2012 13:06:22 GMT
I'm trying to configure the bridge between ActiveMQ and WebSphere MQ, it
seems that connection is established, but unfortunately I don't see any
result.

producer ==> ActiveMQ <<=bridge=>> WebSphere ==> consumer

Configuration file activemq.xml:

<beans
xmlns="http://www.springframework.org/schema/beans"
xmlns:amq="http://activemq.apache.org/schema/core"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans.xsd
http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd">

	<bean
class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer">
		<property name="locations">
			<value>file:${activemq.conf}/credentials.properties</value>
		</property>
	</bean>
	<broker xmlns="http://activemq.apache.org/schema/core"
brokerName="localhost" dataDirectory="${activemq.data}">
		<destinationPolicy>
			<policyMap>
				<policyEntries>
					<policyEntry topic=">" producerFlowControl="true">
						<pendingMessageLimitStrategy>
							<constantPendingMessageLimitStrategy limit="1000"/>
						</pendingMessageLimitStrategy>
					</policyEntry>
					<policyEntry queue=">" producerFlowControl="true" memoryLimit="1mb">
					</policyEntry>
				</policyEntries>
			</policyMap>
		</destinationPolicy>

		<managementContext>
			<managementContext createConnector="false"/>
		</managementContext>

		<persistenceAdapter>
			<kahaDB directory="${activemq.data}/kahadb"/>
		</persistenceAdapter>
		<systemUsage>
			<systemUsage>
				<memoryUsage>
					<memoryUsage limit="64 mb"/>
				</memoryUsage>
				<storeUsage>
					<storeUsage limit="100 gb"/>
				</storeUsage>
				<tempUsage>
					<tempUsage limit="50 gb"/>
				</tempUsage>
			</systemUsage>
		</systemUsage>

		<jmsBridgeConnectors>
			<jmsQueueConnector outboundQueueConnectionFactory="#remoteFactory"
name="WebSphere">
				<inboundQueueBridges>
					<inboundQueueBridge inboundQueueName="TESTQUEUE"
localQueueName="TESTQUEUE" />
				</inboundQueueBridges>
				<outboundQueueBridges>
					<outboundQueueBridge outboundQueueName="TESTQUEUE"
localQueueName="TESTQUEUE" />
				</outboundQueueBridges>
			</jmsQueueConnector>
		</jmsBridgeConnectors>

		<transportConnectors>
			<transportConnector name="openwire"
uri="tcp://0.0.0.0:61616?maximumConnections=1000&amp;wireformat.maxFrameSize=104857600"/>
		</transportConnectors>

		<shutdownHooks>
			<bean xmlns="http://www.springframework.org/schema/beans"
class="org.apache.activemq.hooks.SpringContextHook" />
		</shutdownHooks>
	</broker>

	<bean id="remoteFactory" class="com.ibm.mq.jms.MQQueueConnectionFactory">
		<property name="transportType" value="1"/>
		<property name="hostName" value="172.20.38.26"/>
		<property name="port" value="1414"/>
		<property name="queueManager" value="MYQMGR"/>
		<property name="channel" value="MYCHANNEL"/>
	</bean>

	<import resource="jetty.xml"/>
</beans>

Log:

c:\tmp\apache-activemq-5.7.0>bin\activemq
Java Runtime: Oracle Corporation 1.7.0_09 C:\Program Files (x86)\Java\jre7
  Heap sizes: current=1013632k  free=996854k  max=1013632k
    JVM args: -Dcom.sun.management.jmxremote -Xms1G -Xmx1G
-Djava.util.logging.config.file=logging.properties
-Dactivemq.classpath=c:\tmp\apache-activemq-5.7.0\
bin\..\conf;c:\tmp\apache-activemq-5.7.0\bin\../conf;c:\tmp\apache-activemq-5.7.0\bin\../conf;
-Dactivemq.home=c:\tmp\apache-activemq-5.7.0\bin\.. -Dactivemq.ba
se=c:\tmp\apache-activemq-5.7.0\bin\..
-Dactivemq.conf=c:\tmp\apache-activemq-5.7.0\bin\..\conf
-Dactivemq.data=c:\tmp\apache-activemq-5.7.0\bin\..\data -Djava.
io.tmpdir=c:\tmp\apache-activemq-5.7.0\bin\..\data\tmp
Extensions classpath:
 
[c:\tmp\apache-activemq-5.7.0\bin\..\lib,c:\tmp\apache-activemq-5.7.0\bin\..\lib\camel,c:\tmp\apache-activemq-5.7.0\bin\..\lib\optional,c:\tmp\apache-activemq
-5.7.0\bin\..\lib\web,c:\tmp\apache-activemq-5.7.0\bin\..\lib\extra]
ACTIVEMQ_HOME: c:\tmp\apache-activemq-5.7.0\bin\..
ACTIVEMQ_BASE: c:\tmp\apache-activemq-5.7.0\bin\..
ACTIVEMQ_CONF: c:\tmp\apache-activemq-5.7.0\bin\..\conf
ACTIVEMQ_DATA: c:\tmp\apache-activemq-5.7.0\bin\..\data
Loading message broker from: xbean:activemq.xml
 INFO | Refreshing org.apache.activemq.xbean.XBeanBrokerFactory$1@4b99fa:
startup date [Fri Nov 23 13:10:22 CET 2012]; root of context hierarchy
 INFO |
PListStore:[c:\tmp\apache-activemq-5.7.0\bin\..\data\localhost\tmp_storage]
started
 INFO | Using Persistence Adapter:
KahaDBPersistenceAdapter[c:\tmp\apache-activemq-5.7.0\bin\..\data\kahadb]
 INFO | KahaDB is version 4
 INFO | Recovering from the journal ...
 INFO | Recovery replayed 1 operations from the journal in 0.016 seconds.
 INFO | Apache ActiveMQ 5.7.0 (localhost, ID:vm-M1-59436-1353672623624-0:1)
is starting
 INFO | Listening for connections at:
tcp://vm-M1:61616?maximumConnections=1000&wireformat.maxFrameSize=104857600
 INFO | Connector openwire Started
 INFO | Connector vm://localhost Started
 INFO | JMS Connector WebSphere Started
 INFO | Apache ActiveMQ 5.7.0 (localhost, ID:vm-M1-59436-1353672623624-0:1)
started
 INFO | For help or more information please see: http://activemq.apache.org
 WARN | Store limit is 102400 mb, whilst the data directory:
c:\tmp\apache-activemq-5.7.0\bin\..\data\kahadb only has 11973 mb of usable
space
ERROR | Temporary Store limit is 51200 mb, whilst the temporary data
directory: c:\tmp\apache-activemq-5.7.0\bin\..\data\localhost\tmp_storage
only has 11973 mb
 of usable space
 INFO | jetty-7.6.7.v20120910
 INFO | ActiveMQ WebConsole initialized.
 INFO | started
o.e.j.w.WebAppContext{/admin,file:/C:/tmp/apache-activemq-5.7.0/webapps/admin/}
 INFO | Initializing Spring FrameworkServlet 'dispatcher'
 INFO | ActiveMQ Console at http://0.0.0.0:8161/admin
 INFO | started
o.e.j.w.WebAppContext{/demo,file:/C:/tmp/apache-activemq-5.7.0/webapps/demo/}
 INFO | Apache ActiveMQ Web Demo at http://0.0.0.0:8161/demo
 INFO | started
o.e.j.w.WebAppContext{/fileserver,file:/C:/tmp/apache-activemq-5.7.0/webapps/fileserver/}
 INFO | RESTful file access application at http://0.0.0.0:8161/fileserver
 INFO | Started SelectChannelConnector@0.0.0.0:8161

Sended messages aren't seen in WebSphere, they are in ActiveMQ queue
(TESTQUEUE).
Any suggestions?
Maybe I should configure something on the side WebSphere?



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-CPP-with-IBM-WebSphere-MQ-tp4659634p4659694.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message