activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zackhasit <zackha...@gmail.com>
Subject Broker latency spike
Date Tue, 13 Nov 2012 14:57:09 GMT

Hi, I ran the producer/consumer which is delivered as part of the example. I
added code to show difference between JMSActiveMQBrokerInTime and
JMSActiveMQBrokerOutTime. It remains zero for 90% of the time but goes
higher every now and then. I suspected garbage collection and now the broker
parameters are :

/tools/java/jdk1.6.0_29/bin/java -Xms1G -Xmx1G -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:+CMSParallelRemarkEnabled -XX:SurvivorRatio=20
-XX:ParallelGCThreads=8 -Dorg.apache.activemq.UseDedicatedTaskRunner=true
-Djava.util.logging.config.file=logging.properties
-Dcom.sun.management.jmxremote
-Dactivemq.classpath=/apache-activemq-5.5.1/conf;
-Dactivemq.home=/apache-activemq-5.5.1
-Dactivemq.base=/apache-activemq-5.5.1 -jar
/apache-activemq-5.5.1/bin/run.jar start

But I dont see any improvement. I looked at other options like async send
etc but that did not help. Consumers,broker and producers are all on same
server and there is enough CPU and memory (no h/w bottlenecks as far as I
can see...) and examples are using CMS to connect to broker. Any
recommendation on what to try ? Since this is a standard example I am hoping
folks here are already aware of this ?



--
View this message in context: http://activemq.2283324.n4.nabble.com/Broker-latency-spike-tp4659255.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message