activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jsimmonsc <jsimmo...@gmail.com>
Subject XaPooledConnectionFactory
Date Tue, 06 Nov 2012 21:50:11 GMT
Hello,

We are trying to setup ActiveMQ XA transactions with websphere mq and a
postgres database.  We were using ActiveMQ 5.6.0 and camel 2.9.2 inside of a
karaf container with version 2.2.9.

The setup that we used was documented on fusesource website.

Fusesource Documentation
<http://fusesource.com/docs/esbent/7.0/camel_tx/XaJms-Sample.html>  

Everything most works except for the memory leak as outlined in  AMQ-3997
<https://issues.apache.org/jira/browse/AMQ-3997>  .

When we saw the release of active mq 5.7.0, we tried to update all of our
code to use the camel 2.10 series and active mq 5.7.0.  We are now having
problems getting the transaction to enlist in XA transactions.  Looking at
the source code, I cannot find anywhere that calls the createConnecitonPool
in org.apache.activemq.pool.XaPooledConnectionFactory.  It appears that the
PooledConnectionFactory used to delegate to this method, but it does not any
more.

I'm curious as to how this is supposed to work now.  I have tried to look
for any documentation about giving a JmsComponent a connection pool, but
cannot do so.  

Any help on the matter is greatly appreciated.

Josh



--
View this message in context: http://activemq.2283324.n4.nabble.com/XaPooledConnectionFactory-tp4658865.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message