activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jiunjiunma <jiunjiu...@gmail.com>
Subject cannot get connection when using activemq on ec2
Date Tue, 06 Nov 2012 02:33:10 GMT
Hi, 
    I was running activemq with JMS transaction. When I ran activemq on my
localhost, I could get the jms connection and everything worked fine, but
when I tried to use an activemq on EC2, the connection always hang. (If I
turned off the JMS transaction and use no-transactioned route, I have no
problem getting connection from the EC2 activemq so that kind of ruled out
my security group setting.) 
    Had anybody tried to run JMS xa against instance on EC2? Is there any
special setting I have to do? I'd really appreciate your help.

Thanks,
--Jiunjiun

P.S. snippets of my camel setting are as follows:

    <bean id="jmsConnectionFactory"
          class="org.apache.activemq.ActiveMQConnectionFactory">
        <property name="brokerURL" value="${activeMQBrokerURL}"/> 
    </bean>

    <bean id="pooledConnectionFactory"
          class="org.apache.activemq.pool.PooledConnectionFactory"
init-method="start" destroy-method="stop">
        <property name="maxConnections" value="8" />
        <property name="connectionFactory" ref="jmsConnectionFactory" />
    </bean>

    <bean id="jmsConfig"
          class="org.apache.camel.component.jms.JmsConfiguration">
        <property name="connectionFactory" ref="pooledConnectionFactory"/>
        <property name="concurrentConsumers" value="10"/>
    </bean>

    <bean id="transactionManager"
class="org.springframework.jms.connection.JmsTransactionManager">
        <property name="connectionFactory" ref="pooledConnectionFactory"/>
    </bean>

    <bean id="activemq"
class="org.apache.activemq.camel.component.ActiveMQComponent">
        <property name="transacted" value="true"/>
        <property name="transactionManager" ref="transactionManager"/>
        <property name="concurrentConsumers" value="5"/>
    </bean>




--
View this message in context: http://activemq.2283324.n4.nabble.com/cannot-get-connection-when-using-activemq-on-ec2-tp4658822.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message