activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: [MQTT] Impossible to disable InactivityMonitor !
Date Fri, 19 Oct 2012 14:28:03 GMT
Let me know what the JIRA is when you open it.
The wireFormat.maxInactivityDuration=0 option to the connector is not
observed for MQTT in the current code base. Still not sure that it matters,
but I'll check.

I tried to reproduce on the latest code base, but cannot reproduce exactly
as you've described. I'll try again on 5.7.

On Thu, Oct 18, 2012 at 8:58 AM, BoomBoom49 <BoomBoom49@gmail.com> wrote:

> Hi,
>
> I try to migrate from mosquitto to ActiveMQ 5.7.0,
>   - I configure my xml with
>   - my java client send a CONNECT message with a keepAlive set to 0.
>
> but ActivateMQ kill my connection after 30s with a nice
>
>
> When I set a keep alive to 60sec, it works. I mean ActiveMQ kill my
> connection after 60secs.
>
> I have a look to the source of MQTTInactivityMonitor and
> MQTTProtocolConverter
> and it seem impossible to start a MQTTInactivityMonitor with a 0 keepAlive,
> but in my log I have this message :
>
>
> So I really don't understand.
>
> Thx
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/MQTT-Impossible-to-disable-InactivityMonitor-tp4657945.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message