activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Issues with KahaDB persistence in ActiveMQ 5.6.0 (IndexOutOfBoundsException, IllegalStateException)
Date Mon, 22 Oct 2012 11:42:41 GMT
KahaDB is the current default persistence provider, and kaha will be
depreciated in the future.

I agree, the naming is a little confusing, it reflects something of
the evolution of the stores.
There was jdbc, then amq store, then kaha, then kahadb.

KahaDB has been hardening for the past 2 years, since 5.3.  It is the
recommend choice for file based persistence.

On 22 October 2012 12:01, Pauli Kaila <pauli.kaila@napa.fi> wrote:
> It indeed seems that there are two different Kaha persistence adapters, the
> KahaPersistenceAdapter and KahaDBPersistenceAdapter. So what you are saying
> is that the KahaDBPersistenceAdapter should work better? Or were you just
> pointing out an error in my previous post (me talking about KahaDB instead
> of Kaha)?
>
> The fact that there are two so similarly named persistence adapters is quite
> confusing. Perhaps other one should be deprecated.
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Issues-with-KahaDB-persistence-in-ActiveMQ-5-6-0-IndexOutOfBoundsException-IllegalStateException-tp4658031p4658040.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
http://redhat.com
http://blog.garytully.com

Mime
View raw message