activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ishitori <Ishit...@bk.ru>
Subject Re: Consumer hangs on creation
Date Thu, 18 Oct 2012 09:30:47 GMT
I managed to resolve the issue by restarting 2nd broker. But I want to
understand why it is happened.

> Is your client using failover?

Yes, it does. Moreover I am using 2 duplex connectors from one broker to
another with conduitSubscriptions = "false" on both connectors.

If so was there a broker running?

Yes they were running, but I think we expirienced the problem with the 2nd
broker at that moment.

What do the broker logs say?

I can see 

WARN | Transport Connection to: tcp://192.168.0.18:58614 failed:
java.io.EOFException
WARN | Transport Connection to: tcp://192.168.0.18:59866 failed:
java.io.EOFException
WARN | Transport Connection to: tcp://192.168.0.18:59920 failed:
java.io.EOFException

where 192.168.0.18 it is an address of the 2nd broker. So I can guess that
connections between brokers went down for some reason, right?

And a strange information message:

INFO: TopicSubscription: consumer=ID:<Broker1>-65074-1350392991110-8:2:1:1,
destinations=15, dispatched=1000, delivered=6333, matched=39550,
discarded=0: Pending message cursor
[org.apache.activemq.broker.region.cursors.VMPendingMessageCursor@ec2384] is
full, temp usage (15%) or memory usage (100%) limit reached, blocking
message add() pending the release of resources.

I don't use topics in ActiveMQ at all, only named queues. Why it tells me
something about a TopicSubscription where I shouldn't have any?

Any ideas?



--
View this message in context: http://activemq.2283324.n4.nabble.com/Consumer-hangs-on-creation-tp4657882p4657921.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message