activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From VJ_2523 <v.yer...@gmail.com>
Subject Re: Create Queue and sample messages in 4.x version
Date Thu, 27 Sep 2012 13:31:03 GMT
Thanks for the response Claus. 

The reason why I am using 4.x version is because it is using the JDK 1.5
version and I have an ETL application which is using JDK 1.5 on the other
end which talks to the ActiveMQ JMS server to pool the messages from the
queue. 

To begin with, I was using the latest version 5.6.0 of ActiveMQ and I
created a sample Queue and also dropped few messages in the queue using the
web based admin monitor console. But, when my ETL application is trying to
communicate with the JMS server I am getting the below error( I suspected
that the JDK version's are not compatible ). 

java.lang.UnsupportedClassVersionError: Bad version number in .class file

Hence, I downgraded the JMS server to version 4.x because it is using JDK
1.5.
How ever, I could not create a queue on the JMS server to post the messages
but when I was reading the ActiveMQ user guide,  it has some sample JAVA
programs which are using a queue called "MyQueue". 
 
I did few changes on the  ETL application  to look for the messages inside
the queue name "MyQueue" and it was able communicate successfully with the
JMS server but there are no messages available to be processed on the JMS
server inside the queue name "MyQueue".  

Can you please suggest me if I am missing some thing here or if there is any
alternative way that I go for ?

Thanks,
Vijay




--
View this message in context: http://activemq.2283324.n4.nabble.com/Create-Queue-and-sample-messages-in-4-x-version-tp4657005p4657102.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message