activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lin Wen Tong <d.one.ab...@gmail.com>
Subject activeMQ web console is throwing error when slave turns on
Date Wed, 26 Sep 2012 23:12:58 GMT

Hi All,

I have a shared master/slave (kahaDB) setup, and the web console does not
work, when master is killed. I'm using 5.6.0

steps:
1) master starts (grabs the lock)
2) slave starts (acquiring the lock )
3) going to master activemq webconsole (port 8161 ) works.
4) kill -9 master starts
5) slave acquires the lock
6) going to slave activemq webconsole (port 8162) throws an error.

Caused by: javax.management.InstanceNotFoundException:
org.apache.activemq:BrokerName=slaveBroker,Type=Queue,Destination=dlq.queue1
	at
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(DefaultMBeanServerInterceptor.java:1094)
	at
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getAttribute(DefaultMBeanServerInterceptor.java:662)
	at
com.sun.jmx.mbeanserver.JmxMBeanServer.getAttribute(JmxMBeanServer.java:638)
	at
javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:263)



Howerver, if I start slave (as the master), it works fine.

Any help will be greatly appreciated.


Wen Tong



--
View this message in context: http://activemq.2283324.n4.nabble.com/activeMQ-web-console-is-throwing-error-when-slave-turns-on-tp4657056.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message