activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From edub <>
Subject Validating Connection Pools and Counting # of Connections
Date Mon, 24 Sep 2012 21:01:18 GMT

This is sort-of a cross between Camel and ActiveMQ, but I cannot determine
which side it falls under.  I have a camel context that connects with 2
routes.  One of the routes consumes from a network of brokers (8 total) and
another produces to that same network.  In production I will have many of
these sites so I’m trying to reduce my connection count as much as possible. 
I have connection pooling set up and I was under the impression that a
producer and consumer would share the same connection.  However, unless I’m
reading it wrong, under the connections tree, or tab in the webconsole, I’m
seeing connections on almost all my brokers.  I’m using a failover URI with
all 8 broker URLs listed.  The brokers are configured with the
“auto-rebalance” setting.  

It appears my consumers are all connected to the same broker no matter what,
so I assume that connection pooling is working in this case.  However, I
cannot validate that the producer is sharing the same connection or not.

I’m noticing, that almost all my brokers list a connection coming from this
server when auto-balance is enabled.  When I shut down the routes,  all
connections go away.  So I’m having a difficult time determing if my
connection pooling is working or not.

I guess I need to understand if a prodcuer can share a connection with a
consumer, if so, how can I validate that is really happening  and should I
be seeing all these other connections to the other brokers?

I’m using ActiveMQ 5.6 with a mix of clients from 5.4.2 to 5.6 and getting
the same results.  I’m happy to share any other detais, but I’m not really
sure what else is relavant at this time.


View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message