activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pollotek <claudio.sant...@gmail.com>
Subject FailOver transport not reconnecting
Date Tue, 18 Sep 2012 03:52:21 GMT
Hi all,

I have several embedded brokers connected to a stand alone broker. When the
stand alone broker restarts SOME embedded broker clients are not
reconnecting. This is the message I see:

03:26:34,722  WARN FailoverTransport:250 - Transport
(tcp://mqbroker01:61616) failed, reason:  java.net.SocketException:
Connection reset, not attempting to automati
cally reconnect
03:26:34,723  INFO DemandForwardingBridgeSupport:597 - Network connection
between vm://localhost?async=true#130 and unconnected shutdown due to a
local error: java.ne
t.SocketException: Connection reset
03:26:34,724  INFO DemandForwardingBridgeSupport:597 - Network connection
between vm://localhost?async=true#130 and unconnected shutdown due to a
local error: java.ne
t.SocketException: Connection reset
03:26:34,724  INFO DiscoveryNetworkConnector:115 - Establishing network
connection from vm://localhost?async=false&network=true to
failover:(tcp://mqbroker01:61616,tc
p://mqbroker02:61616)?randomize=false&maxReconnectAttempts=0
03:26:34,725  INFO DemandForwardingBridgeSupport:597 - Network connection
between vm://localhost?async=true#130 and unconnected shutdown due to a
local error: java.ne
t.SocketException: Connection reset
03:26:34,741  INFO DemandForwardingBridgeSupport:353 - localhost bridge to
broker stopped
03:26:34,765 ERROR FailoverTransport:1026 - Failed to connect to
[tcp://mqbroker01:61616, tcp://mqbroker02:61616] after: 1 attempt(s)
03:26:34,807  WARN DemandForwardingBridgeSupport:363 - Network connection
between vm://localhost?async=true#140 and unconnected shutdown due to a
remote error: java.n
et.ConnectException: Connection refused

This is my networkConnectors configuration:

        <amq:networkConnectors>
                       <amq:networkConnector
name="connection_to_nob-_STARTPREFIXactivemq.brokerid_ENDSUFFIX"
                                             
uri="static:failover:(tcp://mqbroker01:61616,
tcp://mqbroker02:61616)?randomize=false&amp;maxReconnectAttempts=0"
                                              duplex="false"/>
        </amq:networkConnectors>


I don't like having to wait for random behavior when the stand alone broker
bounces and having to bounce the clients to restablish connection.

I'm using ActiveMQ 5.6 on the stand alone broker and embedded broker
clients.



--
View this message in context: http://activemq.2283324.n4.nabble.com/FailOver-transport-not-reconnecting-tp4656549.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message