activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S├ębastien Lorber <lorber.sebast...@gmail.com>
Subject ActiveMQ has too many dependencies?
Date Mon, 27 Aug 2012 14:53:15 GMT
Hello,

After some troubles with the following stacktrace while running my
webapplication with Jetty,

java.lang.NoSuchMethodError:
org.eclipse.jdt.internal.compiler.CompilationResult.getProblems()[Lorg/eclipse/jdt/core/compiler/CategorizedProblem;

        at
org.apache.jasper.compiler.JDTCompiler$2.acceptResult(JDTCompiler.java:354)
        at
org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:335)
        at
org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:413)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:308)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:286)
        at org.apache.jasper.compiler.Compiler.compile(Compiler.java:273)
        at
org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:566)

        at
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317)

        at
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
        at
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
.......



I've checked the maven dependencies of ActiveMQ

[INFO] +- org.apache.activemq:activemq-core:jar:5.6.0:compile
[INFO] |  +- org.slf4j:slf4j-api:jar:1.6.1:compile
[INFO] |  +-
org.apache.geronimo.specs:geronimo-jms_1.1_spec:jar:1.1.1:compile
[INFO] |  +- org.apache.activemq:kahadb:jar:5.6.0:compile
[INFO] |  +- org.apache.activemq.protobuf:activemq-protobuf:jar:1.1:compile
[INFO] |  +- *org.fusesource.fuse-extra:fusemq-leveldb:jar:1.1:compile*
[INFO] |  |  +- org.fusesource.hawtbuf:hawtbuf-proto:jar:1.9:compile
[INFO] |  |  +-
org.fusesource.hawtdispatch:hawtdispatch-scala:jar:1.9:compile
[INFO] |  |  |  \- org.fusesource.hawtdispatch:hawtdispatch:jar:1.9:compile
[INFO] |  |  +- org.iq80.leveldb:leveldb:jar:0.2:compile
[INFO] |  |  |  +- org.iq80.leveldb:leveldb-api:jar:0.2:compile
[INFO] |  |  |  +- com.google.inject:guice:jar:3.0:compile
[INFO] |  |  |  |  \- javax.inject:javax.inject:jar:1:compile
[INFO] |  |  |  \-
com.google.inject.extensions:guice-multibindings:jar:3.0:compile
[INFO] |  |  +- org.fusesource.leveldbjni:leveldbjni-osx:jar:1.2:compile
[INFO] |  |  |  \- org.fusesource.leveldbjni:leveldbjni:jar:1.2:compile
[INFO] |  |  |     \- org.fusesource.hawtjni:hawtjni-runtime:jar:1.5:compile
[INFO] |  |  +- org.fusesource.leveldbjni:leveldbjni-linux32:jar:1.2:compile
[INFO] |  |  +- org.fusesource.leveldbjni:leveldbjni-linux64:jar:1.2:compile
[INFO] |  |  +- org.xerial.snappy:snappy-java:jar:1.0.3:compile
[INFO] |  |  +- org.codehaus.jackson:jackson-core-asl:jar:1.9.2:compile
[INFO] |  |  +- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.2:compile
[INFO] |  |  +- *org.apache.hadoop:hadoop-core:jar:1.0.0:compile*
[INFO] |  |  |  +-
commons-configuration:commons-configuration:jar:1.6:compile
[INFO] |  |  |  |  \- commons-digester:commons-digester:jar:1.8:compile
[INFO] |  |  |  +- *org.mortbay.jetty:jetty:jar:6.1.26:compile*
[INFO] |  |  |  |  \- *
org.mortbay.jetty:servlet-api:jar:2.5-20081211:compile*
[INFO] |  |  |  +- *org.mortbay.jetty:jetty-util:jar:6.1.26:compile*
[INFO] |  |  |  +- *org.mortbay.jetty:jsp-api-2.1:jar:6.1.14:compile*
[INFO] |  |  |  |  \- *org.mortbay.jetty:servlet-api-2.5:jar:6.1.14:compile*
[INFO] |  |  |  \- *org.mortbay.jetty:jsp-2.1:jar:6.1.14:compile*
[INFO] |  |  |     \- ant:ant:jar:1.6.5:compile
[INFO] |  |  \- *org.scala-lang:scala-library:jar:2.9.1:compile*
[INFO] |  +- org.fusesource.mqtt-client:mqtt-client:jar:1.0:compile
[INFO] |  |  +-
org.fusesource.hawtdispatch:hawtdispatch-transport:jar:1.9:compile
[INFO] |  |  \- org.fusesource.hawtbuf:hawtbuf:jar:1.9:compile
[INFO] |  +- org.osgi:org.osgi.core:jar:4.1.0:compile
[INFO] |  +-
org.apache.geronimo.specs:geronimo-j2ee-management_1.1_spec:jar:1.0.1:compile
[INFO] |  +- org.springframework:spring-context:jar:3.0.5.RELEASE:compile
[INFO] |  |  +-
org.springframework:spring-expression:jar:3.0.5.RELEASE:compile
[INFO] |  |  \- org.springframework:spring-asm:jar:3.0.5.RELEASE:compile
[INFO] |  +- commons-net:commons-net:jar:2.2:compile
[INFO] |  \- org.jasypt:jasypt:jar:1.8:compile




As i supposed i had a transitive dependency that was getting me a wrong
version of some servlet/jsp thing that is already embedded in my jetty.

But I just wonder, wouldn't it be better to make the dependency to
fusemq-leveldb optional?
I mean, it's a bit weird to retrieve Hadoop and Scala because of a part of
ActiveMQ you probably won't use...

And it will produce conflicts by default to many jetty users like me i
guess.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message