activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From akshay131 <akshaypathak...@gmail.com>
Subject Active MQ - timeout - any alternate option in v5.2?
Date Tue, 28 Aug 2012 11:44:21 GMT
I am using Active MQ v5.2.0 with failover transport and Master/Slave config.

JMS publish message works fine if either Master or Slave is up and running.

Problem occurs when Master/Slave both are down. When my application tries to
publish message at this time, it won't connect to MQ (since its down) as
well as no JMSException occurs for connect failure (as failover transport is
used). So it actually gets stuck during JMS Send and control does not
return.

The solution seems to be transport option - *maxReconnectAttempts,
initialReconnectDelay, maxReconnectDelay*.  When using them I am getting
exception, control is coming back and program is not getting stuck but when
Active MQ is up again, my application is unable to connect back. The assumed
reason is use of singleton for connection bean (which is must use for my
application). 

*Timeout* option when I tried in my application using v5.6.0, it worked
properly. Basically *timout* is the exact solution to my problem as this
option provides a timeout at jms send option where my application is getting
stuck. 

But the sad part is *timeout *option is not supported in v 5.2.0  and even i
can't upgrade new version.

Is there any alternative for timeout in v5.2.0? or any other solution for my
problem



--
View this message in context: http://activemq.2283324.n4.nabble.com/Active-MQ-timeout-any-alternate-option-in-v5-2-tp4655689.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message