activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bryce <br...@mbsys.us>
Subject Re: Certificate unknown error AFTER failover enabled
Date Thu, 23 Aug 2012 16:30:38 GMT
Yes it is related to that JIRA. The JIRA says that 5.7 fixes this is, BUT I
have re-tested my test code with the 5.7 snapshot and setKeyAndTrustManagers
does not work.

I find two workaround: one using System.setProperty, the other using
Thread.setSslContext. But these are workarounds and I'd rather do things the
appropriate way.

http://activemq.2283324.n4.nabble.com/file/n4655495/ActiveMQFailoverTest.zip
ActiveMQFailoverTest.zip 

The above zip file contains a modified version of what I previously posted
(included is a readme.txt of how to compile and run). This version uses the
5.7 snapshot Jars with the same error coming up as with the 5.5.1 Jars. 

I don't know why the JIRA says this issue is resolved. Maybe for them it
worked. I'll try and add a different JIRA linking to the old JIRA. 





--
View this message in context: http://activemq.2283324.n4.nabble.com/Certificate-unknown-error-AFTER-failover-enabled-tp4655212p4655495.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message