activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joesan <codeintheo...@gmail.com>
Subject Re: ActiveMQ Master / Slave Message Integrity
Date Tue, 21 Aug 2012 15:22:18 GMT
I just performed the following test on my Master / Slave:

Started AMQ1 and AMQ2 - Both runs on the same host but with a different port

Started my Consumer and Producer - Both have the fail-over protocol to
connect to the AMQ

I send messages using my producer in a loop... where with every 10 seconds
gap 10 messages are sent

Checking the log files of the Consumer, I can confirm that the Consumer is
receiving the messages

I open the admin console and I could see the Messages En-queued and Messages
De-queued are 80 and 70 respectively

Now I shutdown my AMQ1. The AMQ2 picks up the lock from the shared file
system. Now the actual problem starts:

(1) When the AMQ2 is fully started, I open the admin console and under
Topics, I see the Messages En-queued and Messages De-queued to be 0. What
happened to the remaining 10 messages that were pending to be De-queued? I
used a durable producer.

(2) I do not understand why my Consumer shuts down and does not fail over at
all

(3) When I do this shutdown startup a couple of times between AMQ1 and AMQ2,
I find that the process to acquire the lock by the standby takes a longer
time with each iteration and after the third try, even my Producer shuts
down.

I would appreciate if anyone can throw some light on my problems.



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-Master-Slave-Message-Integrity-tp4655369p4655385.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message