activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bryce <br...@mbsys.us>
Subject Certificate unknown error AFTER failover enabled
Date Thu, 16 Aug 2012 14:42:03 GMT
It shouldn't matter too much, but here is the way in which I am utilizing
ActiveMQ...

I am using an embedded ActiveMQ broker (via SslBrokerService) in Java code
for our company's software. I connect to the ActiveMQ broker (via
ActiveMQSslConnectionFactory) from two places: inside the Java code and from
Mirth Connect. 

Everything worked fine until I wanted to enable failover support. I first
set the broker failover flag to true. Then I changed the URL for the
connection from ssl://192.168.1.7:61616 to
failover:(ssl://192.168.1.7:61616)?initialReconnectDelay=100.

The failover seems to be working, but I get this error almost every second:
6936 [ActiveMQ Task-1] ERROR org.apache.activemq.broker.TransportConnector -
Could not accept connection : javax.net.ssl.SSLHandshakeException: Received
fatal alert: certificate_unknown

The certificate used in encryption worked fine before using failover.

Any suggestions?



--
View this message in context: http://activemq.2283324.n4.nabble.com/Certificate-unknown-error-AFTER-failover-enabled-tp4655212.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message