activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neek <>
Subject AMQ 5.6 breaks Stomp 1.0 clients, was: Re: 5.5 to 5.6 upgrade, stomp client suddenly gets "User name [ xyz] or password is invalid."
Date Mon, 23 Jul 2012 04:11:17 GMT
I see that one of the changes going into ActiveMQ 5.6 was Stomp 1.1 support:

Could this have changed the Stomp protocol supported in ActiveMQ such that
my Stomp 1.0 PHP client can no longer communicate with it?  This sounds like
a regression, and so seems unlikely, however the specs at and clearly
show a difference and ActiveMQ 5.6 seems to be breaking Stomp 1.0

This is supported by which
clearly states that no whitespace (ws) should be trimmed from headers.  This
makes an old Stomp 1.0 client completely incompatible with ActiveMQ and its
Stomp 1.1 implementation.  It seems there's no version handshaking going on
in the Stomp protocol, so old clients have no way of working against new
servers because the server has no way of gracefully falling back to the old

I did a bunch of painful debugging that I'll omit here as the situation
seems clear.

Where should we get a PHP Stomp 1.1 client from?  I don't see one bundled
with ActiveMQ and the usual suspects (,, don't offer any fresh leads. 
I see a comment on saying
that the PHP client has been updated, but I don't see where to find this

I'm falling back to ActiveMQ 5.5 for now.  A big red warning flag about
breaking Stomp 1.0 compatibility would have been appreciated.  Perhaps there
was one and I missed it?


View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message