activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SergueiM <e...@idirect.com>
Subject jdbc Master/Slave lockup - no active Master, clients fail
Date Wed, 18 Jul 2012 06:31:30 GMT
Hi,

A jdbc Master/Slave cluster.
The following steps bring me into a 'no Master' state, causing AMQ clients
to fail.

Layout.
two brokers:
- Master, AMQ v.5.6 on Ubuntu 10.04 host;
- Slave, AMQ v.5.5.1 on Win 7 host.
Postgres 9 on yet another Ubuntu 12.04 host. 
Sun Java 6 SDK on all hosts; all 64bit.

Step 1: No connection to DB.
Master looses connection to DB due to networking issues.
- Master does not die;
- Slave does not pickup. 

Step 2:
While Master in its hanging mode I tried to start yet another Slave.
- new Slave came up waiting to become the Master. 
Stopped the newly initialized Slave.

~10 minutes later.

Step 3: Connection is back.
- The earlier broken Master's network connection was restored.
- Master shuts itself down, posting the errors:
ERROR | Failed to update database lock: org.postgresql.util.PSQLException:
An I/O error occured while sending to the backend.
INFO | No longer able to keep the exclusive lock so giving up being a master
INFO | ActiveMQ Message Broker (jdbcBroker, ID:ubu2-55120-1342587112479-0:1)
is shutting down
INFO | Connector default Stopped
INFO |
PListStore:[/opt/activemq-installs/apache-activemq-5.6.0/bin/activemq-data/jdbcBroker/tmp_storage
] stopped
WARN | Exception while rollbacking the connection on shutdown
INFO | ActiveMQ JMS Message Broker (jdbcBroker,
ID:ubu2-55120-1342587112479-0:1) stopped 

- Slave does not pick up, still waiting to become the Master. 

Step 4: No Master
Tried to start the Master again.
- It gets into waiting to become the Master, same as Slave. 

I've got no Master because of the temporary networking issue.

Any ideas how can I avoid it?
Thank you.

-
Serguei




--
View this message in context: http://activemq.2283324.n4.nabble.com/jdbc-Master-Slave-lockup-no-active-Master-clients-fail-tp4654110.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message