activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ChrLipp <Christian.L...@xion.at>
Subject ActiveMQ client on Java 1.4
Date Thu, 12 Jul 2012 15:34:20 GMT
We are using Active MQ in the most current version 5.6.0.
Now we have the problem that a new client has to be connected, unfortunately
this client is developed with IBM JDK 1.4. Adding ActiveMQ to the
application lead to the following error:

2012-07-11-09.50.28.838:ReplicationService - Main   : UNEXPECTED ERROR
OCCURRED: org/apache/activemq/ActiveMQConnectionFactory (Unsupported
major.minor version 50.0)
2012-07-11-09.50.28.838:ReplicationService - Main   : STACK TRACE: 
2012-07-11-09.50.28.839:ReplicationService - Main   :
java.lang.UnsupportedClassVersionError:
org/apache/activemq/ActiveMQConnectionFactory (Unsupported major.minor
version 50.0) 

We don't want to use an older ActiveMQ version, since there are other
applications using the current version. Now my questions (I know the FAQ and
specially
http://activemq.apache.org/can-i-use-activemq-5x-or-later-on-java-14.html):

Are there any ActiveMQ client jars which are usable to connect to Active MQ
5.6.0?
For example is it possible to use an ActiveMQ 4.0 client to connect to
Active MQ 5.6.0?
Is it possible to use any other protocol for this purpose?

If I have to use retrotranslator which is the minimum set on jars I have to
translate? Has anyone the experience with IBM JDK 1.4?

Kind regards, CL

--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-client-on-Java-1-4-tp4653940.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message