activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: ActiveMQ 5.6 stomp object transformation
Date Sun, 24 Jun 2012 13:42:33 GMT
On Sun, 2012-06-24 at 04:32 -0700, gpulido wrote: 
> Hello,
> 
> I'm trying to send a message from a Stomp client to a embedded instance of
> an ActiveMQ 5.6.
> 
> The message is an xml representation of an object, so when I send it to the
> queue using stomp I add the transformation keys to the header:
> 
> "transformation:jms-object-xml"
> 
> When I send the message the activeMQ acknowledges it but receives it as a
> ActiveMQTextMessage instead of an ObjectMessage. So it seems that is
> ignoring the transformation header.
> 
> Using the same configuration, only changing the dependency from ActiveMQ 5.6
> to ActiveMQ 5.4.3 the same message using the same client and with the same
> header worked:
> The embedded activeMQ instance acknowledges the message and it is an
> ObjectMessage instance, and all worked.
> 
> I really need to move up to the 5.6 version, but I also need to be able to
> send messages using the stomp client.
> Anyone could help me to find what am I missing here?
> 
> Thank you

There are unit tests which are working fin for transformation so I'd
suggest that you take a look at those and see if you can create a test
case that demonstrate the scenario that is not working.  Once you have
you should open a Jira issue and attach your test case, this will ensure
that someone can reproduce it when they look into the problem.  

> 
> 
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-5-6-stomp-object-transformation-tp4653524.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.

-- 
Tim Bish
Sr Software Engineer | FuseSource Corp
tim.bish@fusesource.com | www.fusesource.com
skype: tabish121 | twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message