activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gpulido <gabriel.pulidodetor...@gmail.com>
Subject ActiveMQ 5.6 stomp object transformation
Date Sun, 24 Jun 2012 11:32:48 GMT
Hello,

I'm trying to send a message from a Stomp client to a embedded instance of
an ActiveMQ 5.6.

The message is an xml representation of an object, so when I send it to the
queue using stomp I add the transformation keys to the header:

"transformation:jms-object-xml"

When I send the message the activeMQ acknowledges it but receives it as a
ActiveMQTextMessage instead of an ObjectMessage. So it seems that is
ignoring the transformation header.

Using the same configuration, only changing the dependency from ActiveMQ 5.6
to ActiveMQ 5.4.3 the same message using the same client and with the same
header worked:
The embedded activeMQ instance acknowledges the message and it is an
ObjectMessage instance, and all worked.

I really need to move up to the 5.6 version, but I also need to be able to
send messages using the stomp client.
Anyone could help me to find what am I missing here?

Thank you


--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-5-6-stomp-object-transformation-tp4653524.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message