activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Embedded broker to master slave topologies not working on failover
Date Tue, 08 May 2012 14:46:23 GMT
have a read of http://fusebyexample.blogspot.com/2011/11/activemq-network-of-master-slave-broker.html

the key for you will be configuring the network connector between your
embedded broker and the ha pair.


On 7 May 2012 20:52, pollotek <claudio.santana@gmail.com> wrote:
> I am trying to make the following topology work with version 5.5:
>
>  embedded broker -> Redundant failover brokers - > consumers
>
> For redundant fail over brokers I have tried master slave share nothing and
> msater slave shared storage. None of these configurations have actually
> worked.
>
> For shared storage the system starts up well, i can see if i put messages in
> the embedded broker they get consumed normally. If the active broker dies I
> see a message of the new active broker getting a lock in the FS and the
> embedded broker fails over to the new broker. The bad thing is that I don't
> see the consumers getting any more messages after the failover happens. If
> new messages get generated I see them getting queued in the embedded broker
> but they never go anywhere. This is the configuration I'm using on the
> consumers:
>
> failover:(tcp://b1:61618,tcp://b2:61619)?randomize=false&maxReconnectAttempts=0
>
> The same happens if I change the topology to master slave share nothing,
> consumers stop getting messages.
>
> Is it unreasonable to try this sort of topology configuration? I've spent
> several days trying to get this to work chasing forum messages here and
> there unsuccessfully. The only stuff I've seen work just like the site
> explains is network of brokers and master slave share nothing with clients
> directly connected to the brokers instead of embedded brokers.
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Embedded-broker-to-master-slave-topologies-not-working-on-failover-tp4615643.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
http://fusesource.com
http://blog.garytully.com

Mime
View raw message