activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Mielke <tors...@fusesource.com>
Subject Re: MessageListener not delivering any more messages at some point
Date Wed, 30 May 2012 09:30:04 GMT
Hello,

ActiveMQ 5.3.0 is really old. Have you thought of upgrading to the latest broker release 5.5.1?
Chances aren't too bad that your problem has been resolved. 



Torsten Mielke
torsten@fusesource.com
tmielke@blogspot.com


On May 30, 2012, at 11:25 AM, Jeremias Maerki wrote:

> No ideas? As a work-around I'm now thinking about running a scheduled
> task that restarts the MessageListener every hour. That's a work-around
> that shouldn't really be necessary, right? A colleague told me yesterday
> that he did exactly that in a personal project of his. So, I'm probably
> not the only one with this problem, although I couldn't find anything
> related to that on the net.
> 
> Thanks,
> Jeremias Maerki
> 
> 
> On 25.05.2012 12:23:54 Jeremias Maerki wrote:
>> Hi,
>> 
>> I've got an ActiveMQ 5.3.0 broker running in one JVM.
>> 
>>        <transportConnectors>
>>            <transportConnector name="openwire" uri="tcp://localhost:19616"/>
>>        </transportConnectors>
>> 
>> Another application (different JVM but currently on the same machine)
>> connects to that broker to receive messages from a single queue through
>> a MessageListener:
>> 
>> failover://(tcp://localhost:19616?keepAlive=true)?startupMaxReconnectAttempts=5
>> 
>> The message frequency is rather low (5-500 per hour) and can drop to
>> zero over multiple hours (during the night). Every now and then, the
>> MessageListener simply doesn't get any more messages and we have to
>> restart the application for a reconnect despite the failover protocol 
>> (as seen above). We've tried various connection URI parameters but so
>> far, the issue keeps popping up every few weeks. I somehow doubt it has
>> to do with some timeout because, yesterday, it happened during the day
>> during normal business, not in the night after hours of inactivity. When
>> the problem happens, the message producer can still happily add new
>> messages which are then simply piled up.
>> 
>> We first thought that the broker would stop accepting connections at
>> some point but we now have a monitoring agent for Nagios that regularly
>> tries to connect to ActiveMQ to check if anything is wrong on that side,
>> but that proved to be in vain. So, everything is solid on the broker
>> side.
>> 
>> The client used to run ActiveMQ 5.3.0, too (just the
>> ActiveMQConnectionFactory, no broker). We also tried 5.5.1 on the client
>> side but nothing has changed.
>> 
>> I was wondering if anyone has a good idea on this problem.
>> 
>> Thanks a lot,
>> Jeremias Maerki
> 





Mime
View raw message