activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Messages stuck in pending
Date Tue, 08 May 2012 16:36:13 GMT
Hi Luke,

could you check the number of consumer on the queue ?

I saw a similar issue where my consumer was present while the load was 
not too high, and on heavy load, the consumer disappears and so the 
messages stayed in pending.

Regards
JB

On 05/08/2012 06:27 PM, Luke Noel-Storr wrote:
> I have a problem where messages seem to be getting stuck in a pending state.
>
> Initially it seemed they only got stuck in this state if there was no
> consumer when the message was sent, and even after a consumer was started,
> they just sat there.  They then seemingly caused all subsequent messages to
> get stuck in a pending state too.  Purging the queue seemed to allow
> messages to get through. My colleagues also had this same problem (on
> separate systems).
>
> This was frustrating enough, but now it seems every message being sent goes
> to pending, and gets no further.  Purging the queue nor restarting activemq
> seem to help.  I seemed to manage to send one message successfully after a
> full machine reboot.
>
> We're sending and receiving messages via JMS.
>
> I'm using 5.5.0.  My colleagues have 5.5.1 (I think).
>
>
> I'm not sure what other information may help diagnose this issue, but let me
> know, and I'll do my best to supply it.
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Messages-stuck-in-pending-tp4617979.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message