activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From liangwb2001 <liangwb2...@gmail.com>
Subject Client can't connect to the Network of Brokers without known server's hostname when rebalance
Date Tue, 29 May 2012 07:53:19 GMT
Hi Dear All: 
    I'm using 5.5,5.6 with 3 broker clusters, when brokers can access each
other with hostname, but clients don't know servers hostname, connect
servers using ip address. The problem is client couldn't connect server when
rebalance because server returns a peer's hostname. Is there any
configuration or some increase to help me decouping with host map in a large
number of clients Env? Some one has asked for, but I have not found a valid
way of it except all clients knew all brokers hostname, any other way? 
   Here is the cient's debug info: 
2012-05-29 15:32:14,789 [ActiveMQ Task-3] - DEBUG FailoverTransport - Doing
rebalance from: tcp://192.168.0.38:61716 to [tcp://debian160:61716,
tcp://t1:61716, tcp://t4:61716] 
2012-05-29 15:32:14,789 [ActiveMQ Task-3] - DEBUG TcpTransport - Stopping
transport tcp:///192.168.0.38:61716 
2012-05-29 15:32:14,789 [ActiveMQ Task-3] - DEBUG FailoverTransport -
Waiting 10 ms before attempting connection. 
2012-05-29 15:32:14,805 [ActiveMQ Task-3] - DEBUG FailoverTransport -
Attempting  0th  connect to: tcp://debian160:61716 
2012-05-29 15:32:17,410 [ActiveMQ Task-3] - DEBUG FailoverTransport -
Connect fail to: tcp://debian160:61716, reason:
java.net.UnknownHostException: debian160 
2012-05-29 15:32:17,410 [ActiveMQ Task-3] - DEBUG TcpTransport - Stopping
transport tcp://debian160:61716 
2012-05-29 15:32:17,410 [ActiveMQ Task-3] - DEBUG FailoverTransport -
Attempting  0th  connect to: tcp://t1:61716 
2012-05-29 15:32:20,016 [ActiveMQ Task-3] - DEBUG FailoverTransport -
Connect fail to: tcp://t1:61716, reason: java.net.UnknownHostException: t1 
2012-05-29 15:32:20,016 [ActiveMQ Task-3] - DEBUG TcpTransport - Stopping
transport tcp://t1:61716 
2012-05-29 15:32:20,016 [ActiveMQ Task-3] - DEBUG FailoverTransport -
Attempting  0th  connect to: tcp://t4:61716

--
View this message in context: http://activemq.2283324.n4.nabble.com/Client-can-t-connect-to-the-Network-of-Brokers-without-known-server-s-hostname-when-rebalance-tp4652771.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message