activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pollotek <claudio.sant...@gmail.com>
Subject Re: Master/Slave issue with Network of Brokers
Date Fri, 04 May 2012 20:15:47 GMT
I'm having a very similar issue. I'm using 5.5 on Linux Ubuntu with Java 6. I
have an embedded broker inside Tomcat forwarding messages to a master slave
share nothing setup. Consumers are in a different machine running Tomcat
connected directly to the master. Everything seems to work just fine while
the master and the embedded broker are initially connected but as soon as
the master dies I get the following message:

12:07:39,755  INFO DemandForwardingBridgeSupport:538 - Stopping network
bridge on shutdown of remote broker
12:07:39,756  WARN DemandForwardingBridgeSupport:434 - Network connection
between vm://localhost#0 and tcp://127.0.0.1:61618 shutdown due to a remote
error: java.io.IOException: ShutdownInfo {commandId = 183, responseRequired
= false}
12:07:39,794  INFO DemandForwardingBridgeSupport:424 - localhost bridge to
mc01master stopped
12:07:39,796  WARN FailoverTransport:231 - Transport (/127.0.0.1:61618)
failed to tcp://127.0.0.1:61618 , attempting to automatically reconnect due
to: java.io.EOFException
12:07:39,797  INFO DiscoveryNetworkConnector:107 - Establishing network
connection from vm://localhost?async=false&network=true to
failover://(tcp://127.0.0.1:61618,tcp://127.0.0.1:61619)?randomize=false&maxReconnectAttempts=0
12:07:39,909  INFO FailoverTransport:893 - Successfully reconnected to
tcp://127.0.0.1:61619
12:07:39,977  INFO FailoverTransport:891 - Successfully connected to
tcp://127.0.0.1:61619
12:07:40,155  INFO FailoverTransport:893 - Successfully reconnected to
tcp://127.0.0.1:61619
12:07:40,163  WARN FailoverTransport:231 - Transport (/127.0.0.1:61619)
failed to tcp://127.0.0.1:61619 , attempting to automatically reconnect due
to: java.io.EOFException
12:07:40,168  INFO DemandForwardingBridgeSupport:176 - Outbound transport to
Unknown interrupted.
12:07:40,498  INFO TransportConnection:1188 - Active Slave Broker mc02slave
is attached
12:07:40,500  WARN DemandForwardingBridgeSupport:434 - Network connection
between vm://localhost#4 and tcp://127.0.0.1:61619 shutdown due to a remote
error: javax.jms.InvalidClientIDException: Broker: mc02slave - Client:
NC_localhost_outbound already connected from /10.20.64.134:58469
12:07:41,504  INFO DiscoveryNetworkConnector:107 - Establishing network
connection from vm://localhost?async=false&network=true to
failover://(tcp://127.0.0.1:61618,tcp://127.0.0.1:61619)?randomize=false&maxReconnectAttempts=0
12:07:41,693  INFO FailoverTransport:891 - Successfully connected to
tcp://127.0.0.1:61619
12:07:41,696  WARN FailoverTransport:231 - Transport (/127.0.0.1:61619)
failed to tcp://127.0.0.1:61619 , attempting to automatically reconnect due
to: java.io.EOFException
12:07:41,696  INFO DemandForwardingBridgeSupport:176 - Outbound transport to
Unknown interrupted.
12:07:41,947  INFO TransportConnection:1188 - Active Slave Broker mc02slave
is attached


The consumers don't get any more messages.

When I try to put in a new message I get:

12:09:28,014  WARN DemandForwardingBridgeSupport:807 - Unexpected local
command: SessionInfo {commandId = 2, responseRequired = false, sessionId =
ID:ubuntu-58340-1336158336548-3:2:1001}
12:09:28,015  WARN DemandForwardingBridgeSupport:807 - Unexpected local
command: ProducerInfo {commandId = 3, responseRequired = false, producerId =
ID:ubuntu-58340-1336158336548-3:2:1001:1, destination =
queue://queue.destination1, brokerPath = null, dispatchAsync = false,
windowSize = 0}
12:09:28,015  WARN DemandForwardingBridgeSupport:807 - Unexpected local
command: ActiveMQTextMessage {commandId = 4, responseRequired = false,
messageId = ID:ubuntu-58340-1336158336548-3:2:1001:1:1, originalDestination
= null, originalTransactionId = null, producerId =
ID:ubuntu-58340-1336158336548-3:2:1001:1, destination =
queue://queue.destination1, transactionId = null, expiration = 0, timestamp
= 1336158568014, arrival = 0, brokerInTime = 0, brokerOutTime = 0,
correlationId = null, replyTo = null, persistent = true, type = null,
priority = 4, groupID = null, groupSequence = 0, targetConsumerId = null,
compressed = false, userID = null, content = null, marshalledProperties =
null, dataStructure = null, redeliveryCounter = 0, size = 0, properties =
{counter=1001}, readOnlyProperties = true, readOnlyBody = true, droppable =
false, text = Test message  number 1001 created at 13361585...************}


I can't really point the network connectors of the master and slave back at
the consumers because I have too many of them. 

Any ideas?

--
View this message in context: http://activemq.2283324.n4.nabble.com/Master-Slave-issue-with-Network-of-Brokers-tp2354370p4609645.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message