activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pvbouwel <peter.vanbou...@contribute.be>
Subject ActiveMQ Resource Adapter on a Glassfish cluster
Date Thu, 03 May 2012 13:11:11 GMT
Hi,

I wanted to realize the following setup:
2 Glassfish instances (MasterInstance,SlaveInstance) that are part of a
cluster.  And 2 ActiveMQ brokers who run independent of Glassfish (not
embedded).  I want the Glassfishinstances to access the ActiveMQ brokers
using the failover specification and the ActiveMQ brokers are setup in
Master-Slave (with a shared filesystem)

I followed the instructions on
http://geertschuring.wordpress.com/2012/04/20/how-to-connect-glassfish-3-to-activemq-5/
to do the setup.  Except where I have to define the ServerUrl I set
failover:(tcp://master-amq:61616,tcp://slave-amq:61616)

When I create just 1 Glassfish instance and I do the setup everything works.

When I create 2 instances and add them to a cluster, it doesn't work.  I
target the Resource-adapter to the cluster but I cannot access the ActiveMQ
brokers.  When I define a brokerUrl, Glassfish seems to start an embedded
broker and that seems to work as well.  How come it will not work when using
external brokers?  Are there special steps required to realize this kind of
setup?

I am already searching 3 days on this :-).  I thought I had it working but
It was using an embedded broker instead of the external brokers (as I had
defined tcp://localhost:61616 for the property BrokerXmlConfig).

Hopefully there is a solution for my problem.

Kind regards,

--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-Resource-Adapter-on-a-Glassfish-cluster-tp4605977.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message