activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Mielke <tors...@fusesource.com>
Subject Re: [org.apache.activemq.transport.failover.FailoverTransport] (ActiveMQ Task-55) Successfully connected to
Date Wed, 11 Apr 2012 09:59:17 GMT
Hello,

Correct, these log lines indicate that your JBoss client has reconnected to the broker. 
As to why that happened, I don't know. However a reconnect once a day does not sound like
a bigger problem. 
Is there any information in the broker log as to why the connection was shut down?



Cheers,

Torsten Mielke
torsten@fusesource.com
tmielke@blogspot.com


On Apr 11, 2012, at 12:58 AM, qt4x11 wrote:

> We have ActiveMQ clustering between our two servers configured as a network
> of brokers.  Our config files look like
> 
>    <broker xmlns="http://activemq.apache.org/schema/core"
> brokerName="receiver" persistent="false" useJmx="false"
> dataDirectory="${activemq.base}/data"
> destroyApplicationContextOnStop="true">
> 
>        <networkConnectors>
> 
>       <networkConnector
> uri="static:(ssl://le2.comt:61616<http://le1.liveexpert.net:61616/>
> )"/>
> 
>       </networkConnectors>
> 
> 
> and
> 
> 
>        <networkConnectors>
>       <networkConnector
> uri="static:(ssl://le1.comt:61616<http://le1.liveexpert.net:61616/>
> )"/>
>       </networkConnectors>
> 
> 
> We're starting to see some errors in our JBoss logs that look like
> 
> 
> 
> 14:53:37,812 INFO
> [org.apache.activemq.transport.failover.FailoverTransport] (ActiveMQ
> Task-55) Successfully connected to ssl://le2.com:61616?keepAlive=true
> 
> 
> 14:54:30,213 INFO
> [org.apache.activemq.transport.failover.FailoverTransport] (ActiveMQ
> Task-57) Successfully connected to ssl://le2.com:61616?keepAlive=true
> 
> 
> 
> I took a look at the source for
> org.apache.activemq.transport.failover.FailoverTransport - this message
> gets written to log when a successfully reconnection event has been made
> from the client - in this case, Java/JBoss.  Since JBoss is configured with
> jms_url as a static list of brokers, i.e.,
> 
> 
> failover:(
> ssl://le1.com:61616?keepAlive=true,ssl://le2.com:61616?keepAlive=true)
> 
> 
> JBoss attempts to connect to one of the brokers upon startup, the
> connection logic randomizes which broker to connect to by default.  What I
> think is happening when these messages get written is the client has lost
> connection to the broker it has connected to initially, due to hitting the
> inactivityTimeoutThreshold of 30 seconds somehow - and is attempting to
> reconnect to one of the nodes in our network of brokers.  Is this a correct
> assumption?  Is it correct that the Java code running in our JBoss
> container is writing these types of 'reconnect' messages to the logs?  We
> see these messages about once a day, is that too frequent for that period
> of time?  The reason I ask is that some clients are reporting errors, and
> we were able to correlate that to when these 'reconnecton' events appear in
> our logs.
> 
> 
> The reason the client needs to reconnect to the failover cluster is unclear
> to me.  There are no indications of an ActiveMQ server restart at this
> time, just that connection between client and broker needs to be
> reestablished.  Can anyone recommend anything we can do to prevent these
> types of reconnection events from happening as much as possible, given our
> setup?  Or anything we can reconfigure that may be causing frequent
> reconnection events?  Thanks.





Mime
View raw message