activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From woodstockrich <RichPat...@shaw.ca>
Subject Re: HTML/JS works in Demo but not under JBOSS 7.1 / Eclipse
Date Thu, 26 Apr 2012 17:02:58 GMT
Here's my status:

I think part of my problem was that in addition to putting
activemqra-5.5.1.rar to have the message broker into the
standalone/deployments area, I was also putting in the activemq-web.5.5.1
jar by itself.  It was also deployed as part of deploying my application
subsequent to JBOSS server coming up.  So when it started up with JBOSS
start, it wasn't finding everything it needed and also after I deployed my
main project, it probably conflicted.

So I removed the web jar from standalone deployments and JBOSS comes up ok
(before I deploy the project).  I only get this warning, which I am assuming
is inoccuous.

09:45:32,646 WARN  [org.jboss.as.ee] (MSC service thread 1-5) JBAS011006:
Not installing optional component
org.eclipse.jetty.continuation.Servlet3Continuation$1 due to exception:
org.jboss.as.server.deployment.DeploymentUnitProcessingException:
JBAS011054: Could not find default constructor for class
org.eclipse.jetty.continuation.Servlet3Continuation$1
in standalone/deployments I have activemqra-5.5.1.rar and
activemq-web.5.5.1.

Also similar WARN for Servlet3Continuation$2

For the first time, when I deploy my main application (WAR), I don't get any
errors or warnings.

It is only when I start my browser and invoke my URL that I get errors:

09:47:00,620 ERROR [stderr] (http--0.0.0.0-8080-1)
javax.management.InstanceNotFoundException: naming:type=rmiregistry
<snipped stack trace>
09:47:00,683 ERROR [stderr] (JMX connector) Exception in thread "JMX
connector" java.lang.UnsupportedOperationException: JBAS011859: Naming
context is read-only
09:47:01,313 ERROR [stderr] (http--0.0.0.0-8080-1)
javax.management.InstanceNotFoundException: naming:type=rmiregistry
09:47:01,328 ERROR [stderr] (http--0.0.0.0-8080-1)
javax.management.InstanceNotFoundException: naming:type=rmiregistry
09:47:01,351 ERROR [stderr] (JMX connector) Exception in thread "JMX
connector" java.lang.UnsupportedOperationException: JBAS011859: Naming
context is read-only
09:47:02,176 ERROR
[org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/RichJMSDispBoardDemo].[AjaxServlet]]
(http--0.0.0.0-8080-3) Servlet.service() for servlet AjaxServlet threw
exception: java.lang.IllegalStateException: The servlet or filters that are
being used by this request do not support async operation

Then it shuts down the broker.

I'll keep looking...

--
View this message in context: http://activemq.2283324.n4.nabble.com/HTML-JS-works-in-Demo-but-not-under-JBOSS-7-1-Eclipse-tp4584105p4590385.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message