activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: problem getting activemq-admin working on a host with both an internal and external IP address
Date Fri, 02 Mar 2012 13:11:25 GMT
quick thought, does the listener use all interfaces, 0.0.0.0:20112, I
think it will be default but if
com.sun.management.jmxremote.host=someIp is specified it won't

On 1 March 2012 16:59, Geraghty, Colm <colm.geraghty@teamaol.com> wrote:
> hi there
>
> I'm running an activeMQ broker on a CentOS host which has both an internal and external
IP address (I have no control over these settings)
>
> The external address is stored in /etc/hosts lets say 111.222.333.444 and the internal
is returned in the inetAddress on ifconfig - lets say 555.666.777.888
>
> I can successfully access the jmxServer remotely by using the setting :
>
> ACTIVEMQ_SUNJMX_CONTROL="--jmxurl service:jmx:rmi:///jndi/rmi://555.666.777.888:20112/jmxrmi"
>
> and then when connecting via jconsole I use the url :
>
> service:jmx:rmi:///jndi/rmi://111.222.333.444:20112/jmxrmi
>
> so the problem arises when I try to run the 'bin/activemq-admin query' from the same
host. I get the following error :
>
> Connecting to pid: 13063
> ERROR: java.lang.RuntimeException: Failed to execute query task. Reason: java.rmi.ConnectIOException:
error during JRMP connection establishment; nested exception is:
>        java.net.SocketException: Connection reset
> java.lang.RuntimeException: Failed to execute query task. Reason: java.rmi.ConnectIOException:
error during JRMP connection establishment; nested exception is:
>        java.net.SocketException: Connection reset
>        at org.apache.activemq.console.command.QueryCommand.runTask(QueryCommand.java:121)
>
> I also see the following errors on this host in the terminal wondow where the broker
was started :
>
>  INFO | Transport failed: java.io.EOFException
>  INFO | Transport failed: java.io.EOFException
>
> So I guess, the question is - is this a problem caused by the dual IP addresses or is
it a Memory/Resource issue caused by lack of resources on the linux host ?
>
> Also note - I am running the same config on a local linux host with only 1 IP address
and everything works fine
>
> thanks in advance for any help
>
> rgds
> Colm



-- 
http://fusesource.com
http://blog.garytully.com

Mime
View raw message