activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bibudh <bib...@gmail.com>
Subject Problem starting ActiveMQ on MacOS
Date Thu, 29 Mar 2012 21:05:30 GMT
  Hi,
    I have installed ActiveMQ on MacOS (Lion), and I want to use it with
ActiveMessaging in Rails 3. When I start ActiveMQ with the following
command:

    ./bin/activemq start

    from ACTIVEMQ_HOME (which is /usr/local/Cellar/activemq/5.5.1/libexec),
I get the following messages:

    INFO: Loading '/Users/bibudhlahiri/.activemqrc'
    INFO: Using java '/usr/bin/java'
    INFO: Starting - inspect logfiles specified in logging.properties and
log4j.properties to get details
    INFO: pidfile created :
'/usr/local/Cellar/activemq/5.5.1/libexec/data/activemq.pid' (pid '10995')

   But, when I run 

     ./bin/activemq status

   it gives 

      INFO: Loading '/Users/bibudhlahiri/.activemqrc'
      INFO: Using java '/usr/bin/java'
      ActiveMQ not running

   Any idea how to start ActiveMQ? Also, there are three copies of activemq:

  1) ./bin/activemq
  2) ./libexec/bin/activemq
  3) ./libexec/bin/macosx/activemq

    I can see 1) calls 2). 3) for MacOSX has a different code and it gives
the following message

    Starting ActiveMQ Broker...

   when I issue "./libexec/bin/macosx/activemq start", 

    but when I check with 

    ./libexec/bin/macosx/activemq status

    it says 

     ActiveMQ Broker is not running.

     Appreciate your help.

--
View this message in context: http://activemq.2283324.n4.nabble.com/Problem-starting-ActiveMQ-on-MacOS-tp4517005p4517005.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message