activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: purge command in activemq-admin app does not work with selectors
Date Wed, 29 Feb 2012 20:07:37 GMT
hmm, not sure. It looks like all of the relevant code changes are in
the commands and not on the broker.
Have a peek at the test for this feature[1] to verify what is known to
work and the syntax.
then if possible, please reopen that issue with a broker test case
that demonstrates the problem you are seeing

[1] http://svn.apache.org/viewvc/activemq/trunk/activemq-console/src/test/java/org/apache/activemq/console/command/TestPurgeCommand.java?view=markup

On 29 February 2012 18:40, johneboyer <johnboyer99@gmail.com> wrote:
> Hi Gary:
>
> I tried the 5.6 snapshot and it still does not work. I’m looking for a
> pattern in a property, specifically, a domain (example.com) and the query
> fails to find it. I’ve tried a number for variations to no avail.
>
> activemq-admin purge --msgsel prop_name='% example.com' queue_name.*
> activemq-admin purge --msgsel prop_name='* example.com' queue_name.*
> activemq-admin purge --msgsel prop_name LIKE '% example.com' queue_name.*
> activemq-admin purge --msgsel prop_name LIKE '* example.com' queue_name.*
>
> Do you have any suggestions?
>
> Thank you!
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/purge-command-in-activemq-admin-app-does-not-work-with-selectors-tp4430249p4432527.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
http://fusesource.com
http://blog.garytully.com

Mime
View raw message