activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hiram Chirino <hi...@hiramchirino.com>
Subject Re: Apollo (1.0) disconnected after 5 seconds
Date Mon, 06 Feb 2012 17:48:18 GMT
Hi,

I've updated the docs with those details at:
http://activemq.apache.org/apollo/versions/1.1-SNAPSHOT/website/documentation/user-manual.html#Connectors

Basically you need something like:

<connector id="tcp" bind="tcp://0.0.0.0:61613">
  <detect timeout="30000"/>
</connector>


You find a link to the SNAPSHOT build on the download page at:
http://activemq.apache.org/apollo/download.html#Apollo_1_1-SNAPSHOT

On Mon, Feb 6, 2012 at 10:15 AM, Lars-Erik Helander <lehswe@gmail.com>wrote:

> Sounds great, thanks.
> From Jira it looked like you already committed code to svn. If I would
> build from svn, would I get the functionality wanted? How to configure the
> new "option"?
>
> Kind Regards
> Lars
>
> Skickat från min iPhone
>
> 6 feb 2012 kl. 14:46 skrev Hiram Chirino <hiram@hiramchirino.com>:
>
> > Ok.  Opened up https://issues.apache.org/jira/browse/APLO-151
> > Should be simple to support.
> >
> > On Mon, Feb 6, 2012 at 7:58 AM, Lars-Erik Helander <lehswe@gmail.com>
> wrote:
> >
> >> Hi Hiram
> >>
> >> Thanks for your clarification.
> >> I am new to Apollo and STOMP and I viewed the possibility to manually
> >> interact with the broker as I nice way to learn more about the
> >> protocol/broker. Do you know of any terminal software that would allow
> >> me to send an initial "CONNECT frame"-string as part of the connection
> >> procedure? I understand your DoS concerns, but if it would be possible
> >> to configure the broker, either by making the "disconnect time"
> >> configurable or enable/disable the disconnect function, that would be
> >> great.
> >>
> >> Kind Regards
> >> Lars
> >>
> >> 2012/2/6 Hiram Chirino <hiram@hiramchirino.com>:
> >>> Hi Lars,
> >>>
> >>> Apollo expects clients to send the first CONNECT frame within 5 seconds
> >>> otherwise it terminates the connection.  This is in place to help avoid
> >>> denial of service attacks from un-authenticated users.  Do you need it
> >> that
> >>> timeout to be longer?
> >>>
> >>> On Sun, Feb 5, 2012 at 3:17 PM, Lars-Erik Helander <lehswe@gmail.com>
> >> wrote:
> >>>
> >>>> When I try to connect (using a telnet-client) to the apollo broker,
> >>>> the connection is established and after 5 seconds the broker
> >>>> disconnects the connection.
> >>>>
> >>>> Any ideas what might be the problem? I have tested on both Linux and
> >>>> Windows, local and remote and using several different client programs.
> >>>>
> >>>> Kind Regards
> >>>>
> >>>> Lars
> >>>>
> >>>
> >>>
> >>>
> >>> --
> >>>
> >>> **
> >>>
> >>> *Hiram Chirino*
> >>>
> >>> *Software Fellow | FuseSource Corp.*
> >>>
> >>> *chirino@fusesource.com | fusesource.com*
> >>>
> >>> *skype: hiramchirino | twitter: @hiramchirino<
> >> http://twitter.com/hiramchirino>
> >>> *
> >>>
> >>> *blog: Hiram Chirino's Bit Mojo <http://hiramchirino.com/blog/>*
> >>>
> >>> *
> >>> *
> >>>
> >>> *
> >>> *
> >>
> >
> >
> >
> > --
> >
> > **
> >
> > *Hiram Chirino*
> >
> > *Software Fellow | FuseSource Corp.*
> >
> > *chirino@fusesource.com | fusesource.com*
> >
> > *skype: hiramchirino | twitter: @hiramchirino<
> http://twitter.com/hiramchirino>
> > *
> >
> > *blog: Hiram Chirino's Bit Mojo <http://hiramchirino.com/blog/>*
> >
> > *
> > *
> >
> > *
> > *
>



-- 

**

*Hiram Chirino*

*Software Fellow | FuseSource Corp.*

*chirino@fusesource.com | fusesource.com*

*skype: hiramchirino | twitter: @hiramchirino<http://twitter.com/hiramchirino>
*

*blog: Hiram Chirino's Bit Mojo <http://hiramchirino.com/blog/>*

*
*

*
*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message