activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Johnston <chjoh...@gmail.com>
Subject Re: No network bridges started in Network of brokers.
Date Tue, 24 Jan 2012 18:22:03 GMT
Right - I believe thats called a mesh topology which is similar to what I
have setup with the exception that I am using 6 brokers to scale out a bit
more horizontally.  Here is a good example setup from the mcollective
project.  Its pretty much exactly what you are looking for I believe.  And
yes I think you need duplex enabled to maintain the openwire connection
between all the brokers in the mesh.

http://anonscm.debian.org/gitweb/?p=pkg-puppet/mcollective.git;a=tree;f=ext/activemq/examples/multi-broker-mesh;h=c6052e440641fe49de24b174d93b7fef9bd88f0c;hb=HEAD

On Tue, Jan 24, 2012 at 11:42 AM, Laures <baetz.alexander@googlemail.com>wrote:

> i'm trying to create a hypercube (6 servers in 3 nodes (master+slave)).
>
> 3 has connections to 1,2
> 2 has connections to 1,3
> 1 has connections to 2,3
>
> but the activemq doesn't create bridges to all servers so it doesn't get
> advisories from them. no advisories means no awarenes of consumers on these
> servers. so the server without bridges doesn't send his messages through
> the
> cluster.
>
> do you think turning on duplex would fix this?
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/No-network-bridges-started-in-Network-of-brokers-tp4323506p4324295.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message