activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Thompson <dave.thomp...@elmbridgetech.com>
Subject RE: Help with Apache NMS and Apache Apollo
Date Fri, 06 Jan 2012 16:53:32 GMT
Tim,

Thanks very much. I'll download that and try it out.

Just for reference purposes - is there any documentation or sample code floating around for
a STOMP connection, or is it just a case of trial and error?

Thanks,

Dave

-----Original Message-----
From: Timothy Bish [mailto:tabish121@gmail.com] 
Sent: 06 January 2012 16:51
To: users@activemq.apache.org
Subject: RE: Help with Apache NMS and Apache Apollo

On Fri, 2012-01-06 at 16:42 +0000, Dave Thompson wrote:
> Tim,
> 
> Thanks for your response!
> 
> I'm currently using NMS 1.5.1 and Apollo 1.0-beta6 - does that sound like the correct
versions? I assume they should chatter quite happily between themselves even though NMS only
supports STOMP 1.0...
> 
> I do wonder whether there's anything else I need to consider as I'm running this under
Windows 7 x64 with the x64 JDK... specifically, I need to delete the Data directory of my
broker instance every time I restart or I get  an error when restarting the broker - ERROR
| Store client startup failure: java.lang.NoClassDefFoundError: org/xerial/snappy/Snappy.
> 
> Thanks very much for your help...
> 
> Dave

There were some fixes in Stomp v1.5.2 that you need, download that and it should work.

Regards
Tim.


> 
> -----Original Message-----
> From: Timothy Bish [mailto:tabish121@gmail.com]
> Sent: 06 January 2012 16:35
> To: users@activemq.apache.org
> Subject: Re: Help with Apache NMS and Apache Apollo
> 
> On Fri, 2012-01-06 at 16:04 +0000, Dave Thompson wrote:
> > Hello all,
> > 
> > Is there any documentation available for trying to connect Apache NMS to Apache
Apollo? I'm trying my hardest to do this myself, but NMS just won't connect to the broker,
giving a "Unable to read data from the transport connection: An existing connection was forcibly
closed by the remote host" when trying to create a consumer.
> > 
> > Can anyone please point me in the direction of a sample? I can't 
> > believe I'm the only person to have ever done this :)
> > 
> > Thanks very much in advance,
> > 
> > Dave
> 
> Are you using Apache.NMS.Stomp v1.5.2 ?  Apollo supports Stomp right now, the openwire
bits are still unstable.
> 
> Regards
> 
> 
> --
> Tim Bish
> ------------
> FuseSource
> Email: tim.bish@fusesource.com
> Web: http://fusesource.com
> Twitter: tabish121
> Blog: http://timbish.blogspot.com/
> 
> 
> 
> 



Mime
View raw message