activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Pavlovich <mattr...@gmail.com>
Subject Re: Inclusion of <plugins><statisticsBrokerPlugin></plugins> in activemq.xml fails.
Date Tue, 24 Jan 2012 20:51:40 GMT
Hi Bill-

Try adding the closing "/" to the statisticsBrokerPlugin element:

<plugins>
<statisticsBrokerPlugin/>
</plugins>

Tip: Also, when working with configs.  Starting AMQ with the 'console' 
option.

./bin/activemq console

Hope this helps!

Matt Pavlovich

On 1/6/12 10:28 AM, Bill Moo wrote:
> Hello Users,
>
> I am tring to use this feature of ActiveMQ v5.5.1 but when I include these
> elements within the<broker>  </broker>  elements of the activemq.xml file
> activemq fails to start and outputs
>
> ... Line 50 in XML document from class path resource [activemq.xml] is
> invalid; nested exception is org.xml.sax.SAXParseException; lineNumber: 50;
> columnNumber: 18; cvc-complex-type.2.4.a: Invalid content was found
> starting with element 'plugins'. One of '{WC[##other:"
> http://activemq.apache.org/schema/core"]}' is expected.
> ...
>
> But everywhere I look including
> http://activemq.apache.org/statisticsplugin.html and both my ActiveMQ
> and Camel in Action Books tell the same thing that this is all that is
> apparently required.
>
> I am using v5.5.1 on OpenBSD 5.0 amd64 MP with a JDK&  JRE of v1.7.0
> installed via pgk_add and the nano editor.
>
> Any help would be appreciated.
>

Mime
View raw message