activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin C." <mart...@gmx.at>
Subject Re: [newbie] can't get brokers on two computers to connect
Date Mon, 05 Dec 2011 07:29:47 GMT
Hi,

please first ensure your network setup is correct by simply trying to
each other's ports via telnet. I think you still have some basic
networking issues here.

Please also beware that you seem to not create duplex connections,
which means that you have to create a connection from both sides.

Best regards,
Martin

On Mon, Dec 5, 2011 at 6:39 AM, Curtis Bradley <curtis.bradley@yahoo.com> wrote:
> Didn't work.  Please keep the suggestions coming!
>
> This network (my home) is DHCP.  I reserved the IPs and created hostnames on
> each platform:
>
> == Windows (brokerA.xml) =============
> <beans
>  xmlns="http://www.springframework.org/schema/beans"
>  xmlns:amq="http://activemq.apache.org/schema/core"
>  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>  xsi:schemaLocation="http://www.springframework.org/schema/beans
> http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
>  http://activemq.apache.org/schema/core
> http://activemq.apache.org/schema/core/activemq-core.xsd">
>
>    <broker xmlns="http://activemq.apache.org/schema/core"
> brokerName="BrokerA" dataDirectory="${activemq.base}/data">
>
>        <networkConnectors>
>           <networkConnector uri="static:(tcp://homelinuxbox:61617)" />
>        </networkConnectors>
>
>        <transportConnectors>
>            <transportConnector name="openwire" uri="tcp://localhost:61616"
> />
>        </transportConnectors>
>
>    </broker>
>
> </beans>
>
> -- linux (brokerB.xml) --------------------------------
> <beans
>  xmlns="http://www.springframework.org/schema/beans"
>  xmlns:amq="http://activemq.apache.org/schema/core"
>  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>  xsi:schemaLocation="http://www.springframework.org/schema/beans
> http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
>  http://activemq.apache.org/schema/core
> http://activemq.apache.org/schema/core/activemq-core.xsd">
>
>    <broker xmlns="http://activemq.apache.org/schema/core"
> brokerName="BrokerB" dataDirectory="${activemq.base}/data">
>
>        <transportConnectors>
>            <transportConnector name="openwire" uri="tcp://thisbox:61617" />
>        </transportConnectors>
>
>    </broker>
>
> </beans>
>
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/newbie-can-t-get-brokers-on-two-computers-to-connect-tp4156142p4159364.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
View raw message