activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raul Kripalani <r...@fusesource.com>
Subject Re: Upgrade activemq from 4.x to 5.x
Date Mon, 12 Dec 2011 15:48:56 GMT
Hi,

You will also need to think about the persistence layer.
Most likely you will want to adopt KahaDB (which is in fact enabled by
default).

Regards,
Raúl.

On 12 December 2011 15:02, Torsten Mielke <torsten@fusesource.com> wrote:

> Hello,
>
> There is an ActiveMQ 5.5 migration guide [1] available on FuseSource.com.
> Although it covers the migration from 5.4 to 5.5 some of the tips given
> there may also apply to your migration or may at least be useful.
>
> When going from version 4 to 5 you should better recompile your
> application and link against the newer ActiveMQ client libraries.
>
>
> Hope this helps.
>
>
> Torsten Mielke
> torsten@fusesource.com
> tmielke@blogspot.com
>
>
> [1]
> http://fusesource.com/docs/broker/5.5/migration/PersistenceMigration.html
>
>
>
> On Dec 12, 2011, at 3:25 PM, SuoNayi wrote:
>
> > Hi all,How can I upgrade amq from version 4.x to 5.x?
> > What I only know about is that 4.x works on jdk1.4 while 5.x works on
> jdk5+.
> > Is there any guide to introduce how to do this and what should be noted
> for that?
> > Does upgrade need to reconstruct the client source?
> >
> > Thanks.
> >
> > SuoNayi
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message