activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From manua <agarwal.m...@gmail.com>
Subject Java client doesnt work with https
Date Wed, 21 Dec 2011 18:44:54 GMT
HI,

I am trying to getting java consumer work over https.

In my aactivemq.xml at broker side, i have configured ssl and https
transport connectors, 

<transportConnector name="https" uri="https://localhost:8443"/>

At the consumer side (java client), I am specifying the connection factory
as,

ActiveMQConnectionFactory factory = 
               new ActiveMQConnectionFactory("https://localhost:8443");

and while compiling/executing specified the following jar files,

/usr/bin/java -cp
.:lib/activemq-core-5.5.0.jar:lib/javaee.jar:lib/com.zwitserloot.json.jar:lib/slf4j-api-1.5.11.jar:lib/slf4j-log4j12-1.5.11.jar:lib/log4j-1.2.14.jar:lib/commons-logging-1.1.1.jar:lib/commons-codec-1.4.jar:lib/commons-httpclient-3.0.jar:lib/activemq-optional-5.5.0.jar:lib/*
amqTextMessage

This code seems to hang at the statement, 
       connection = factory.createConnection();

If in place of https I specify ssl, then it works fine.

What am I doing wrong.Also, is there a document specifying the https
configuration at the client side.

Please let me know your inputs.

Thanks
Manu


--
View this message in context: http://activemq.2283324.n4.nabble.com/Java-client-doesnt-work-with-https-tp4222791p4222791.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message