activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: SSL certificates not being sent in C# listener connection
Date Wed, 14 Dec 2011 15:45:26 GMT
On Mon, 2011-12-05 at 21:31 -0800, wolfie wrote:
> Hi Original Poster again. 
> 
> Properly solved it this time. The local queue and Java bridge was a
> nightmare short term solution, but it bought me the time to try other stuff
> to get it working properly.
> 
> 1) Export the server certificate as base 64 encoded X.509 CER, private keys
> not included (assume for this example we called the certificate test.cer).
> 
> 2) Include this certificate file in the applications directory, i.e. the
> same folder as the exe file. (I think that it has to be the bin dir for VB
> apps?).
> 
> 3) Use this modifier on the end of the connection ssl url:
> ?transport.clientcertfilename=test.cer
> 
> NOTE: I can't seem to get this working for a windows service, only a windows
> forms application. I think it has something to do with the windows service's
> working directory not being its own directory but rather the window/System32
> dir. I converted my windows service to a windows forms app. Less discrete,
> but actually functional with SSL.
> 

Did you try setting the filename for the client to cert to the full path
of some well known location on the machine?  

Regards

-- 
Tim Bish
------------
FuseSource
Email: tim.bish@fusesource.com
Web: http://fusesource.com
Twitter: tabish121
Blog: http://timbish.blogspot.com/




Mime
View raw message