activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: temp destinations in network of brokers
Date Mon, 14 Nov 2011 11:33:21 GMT
Hi,

this seems like a normal operation, as a message
on ActiveMQ.Advisory.TempQueue indicates that temp queue has been
created/destroyed.

Where do you see those messages? Are you subscribed to that topic?

Regards
-- 
Dejan Bosanac - http://twitter.com/dejanb
-----------------
The experts in open source integration and messaging - http://fusesource.com
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Fri, Nov 11, 2011 at 10:23 PM, R.I.Pienaar <rip@devco.net> wrote:

> hello
>
> I wish to use temp topics (or queues) in a network of brokers
>
> At the most basic level this works fine:
>
> I subscribe to /temp-topic/foo in my stomp client.
> I send a message with that in the reply-to header
>
> On the remote I see reply to translated into
> /remote-temp-queue/ID:monitor2.xx.net-59626-1320978211687-5:3572:1
> and that all works fine.
>
> Immediately after though all the brokers on my network gets completely
> flooded with advisories on ActiveMQ.Advisory.TempQueue:
>
> for example:
>
> {"DestinationInfo": {
>  "commandId": 0,
>  "responseRequired": false,
>  "connectionId": {
>    "value": "ID:monitor2.xx.net-53069-1321036534768-16:2"
>  },
>  "destination": {
>    "@class": "ActiveMQTempQueue",
>    "string": "ID:monitor2.xx.net-53069-1321036534768-5:33:2",
>    "null": {}
>  },
>  "operationType": 1,
>  "timeout": 0
> }}
>
> My brokers are a->b->c so I have a TTL of 2 on the network connections.
>
> Can anyone provide any hints on what I might do to improve the situation
> with
> temp queues or topics on networks of brokers?
>
> thanks!
>
> --
> R.I.Pienaar
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message