activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RagnarZero <ragnarz...@googlemail.com>
Subject ActiveMQ WebSockets not working
Date Wed, 23 Nov 2011 13:16:44 GMT
Hey all,
today I started trying out the websockets transport connector for our amq. I
first tried the 5.5.0 version, which gave me some null pointers when I
wanted to connect. I then learned that it may not understand the newest
websocket protocols, so i changed to the 5.6.-SNAPSHOT and the errors were
gone, but its still not working, only that there are no error messages
anywhere in the console or log. I tried with both of the clients that were
linked to on the WebSockets prage of the AMQ Documentation. I also tried
both Chrome (in Version 15 and 13) and Safari (latest version) but nothing
worked.

Client side error messages are always 404s:
*Jeff Mesnils Client: *
Opening Web Socket...
Whoops! Lost connection to ws://localhost:61614/

(in the console: Unexpected response code: 404)

*In Stomple: *
>>>>
CONNECT
login:guest
passcode:guest


Unexpected response code: 404
socket close


If someone has any idea what could be the problem, I would greatly
appreciate any help :)

Greetings,
Janek


--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-WebSockets-not-working-tp4099533p4099533.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message