activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Mielke <tors...@fusesource.com>
Subject Re: ActiveMq WebConsole Ldap & Roles
Date Thu, 13 Oct 2011 13:31:01 GMT
Perhaps this helps: chapter 6 "LDAP Tutorial" of the ActiveMQ Security Guide available at fusesource.com.
http://fusesource.com/docs/broker/5.5/security/index.html


Torsten Mielke
torsten@fusesource.com
tmielke@blogspot.com

On Oct 13, 2011, at 3:04 AM, Mr.NoBody wrote:

> I am trying to set up ldap auth for the activeMq (5.5.0) web console. 
> I seem to be able to check ldap for the account but am getting a 403 page
> with:
> Problem accessing /. Reason:
> 
>    !role
> 
> when I try and access the web console.
> 
> in the log I see:
> 
> 2011-10-12 14:05:14,485 | INFO  | Searching for users with filter:
> '(&(objectClass={0})({1}={2}))' from base dn: ou=People,dc=XxX,dc=com |
> org.eclipse.jetty.util.log | qtp2099294938-41
> 2011-10-12 14:05:14,491 | INFO  | Found user?: true |
> org.eclipse.jetty.util.log | qtp2099294938-41
> 2011-10-12 14:05:14,492 | INFO  | Attempting authentication:
> uid=XxX,ou=People,dc=XxX,dc=com | org.eclipse.jetty.util.log |
> qtp2099294938-41
> 
> I have debug level set yet i am only seeing info for the ldap attempt.
> 
> Can some one point me to a current example of using ldap and setting the
> roles in the jetty.xml file used by activeMQ or point me in the correct
> direction.
> 
> Thank you,
> 
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMq-WebConsole-Ldap-Roles-tp3900266p3900266.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.





Mime
View raw message