activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Problem with policyEntry from 5.3.0 -> 5.5.0
Date Mon, 24 Oct 2011 15:04:48 GMT
the schema is validated in 5.5 and sequence elements needs to be
ordered alphabetically. put <subscriptionRecoveryPolicy> after
<pendingMessageLimitStrategy>


On 24 October 2011 14:19, cdwillie76 <chris.d.williams@gmail.com> wrote:
> I have a set of policies that we used for our 5.3.0 configuration and when we
> tried to use it with 5.5.0, ActiveMQ won't start. I turned up the logging
> and didn't see anything to indicate what was wrong.  Should this combination
> of policies work?
>
> <policyEntry topic="xxx.yyy.zzz.>" producerFlowControl="false"
> memoryLimit="20mb">
>  <dispatchPolicy>
>    <strictOrderDispatchPolicy/>
>  </dispatchPolicy>
>  <subscriptionRecoveryPolicy>
>    <lastImageSubscriptionRecoveryPolicy/>
>  </subscriptionRecoveryPolicy>
>  <pendingMessageLimitStrategy>
>    <constantPendingMessageLimitStrategy limit="500"/>
>  </pendingMessageLimitStrategy>
> </policyEntry>
>
> Thanks
> Chris
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Problem-with-policyEntry-from-5-3-0-5-5-0-tp3933082p3933082.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
http://fusesource.com
http://blog.garytully.com

Mime
View raw message