activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Victor Perez <vperez.rapidreport...@gmail.com>
Subject Re: STOMP NMS: cannot retrieve messages published from ruby
Date Wed, 28 Sep 2011 20:09:20 GMT
On Wed, Sep 28, 2011 at 1:47 PM, Timothy Bish <tabish121@gmail.com> wrote:

> On Wed, 2011-09-28 at 11:41 -0500, Victor Perez wrote:
> > We have a Ruby app publishing messages to ActiveMQ through STOMP. When I
> use
> > Apache.NMS.Stomp in .NET to consume the messages, they come in as
> > IBytesMessage with no content.
> >
> > If I use NMS to publish a message, it can be consumed with no problems by
> > our ruby, java and NMS (.NET) apps.
> > When i publish the message from ruby, it can be consumed by ruby and java
> > but not NMS.
> >
> > Any ideas?
>
> Capturing the frame that the ruby client is sending would help, also
> knowing what versions of AMQ and .NET client would be good.
>
> Regards
>
> --
> Tim Bish
> ------------
> FuseSource
> Email: tim.bish@fusesource.com
> Web: http://fusesource.com
> Twitter: tabish121
> Blog: http://timbish.blogspot.com/
>
>
>
> AMQ server is 1.5.0
.NET is 1.5.0 for Apache.NMS (from NuGet package) and 1.5.1 for
Apache.NMS.Stomp (compiled from sources)
I have no idea how to capture frames (wireshark?)

I compiled trunk NMS and Stomp and got it to work with latest AMQ (5.5.0)
running locally. Problem persists when using our production AMQ.

Thanks

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message