activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Allen Reese <are...@yahoo-inc.com>
Subject RE: "activemq-admin browse" and authentication
Date Mon, 19 Sep 2011 22:25:10 GMT
You will have to backport this to 5.3.2 and 5.5. 

I had the same issue, and fixed it here:

AMQ-3411 | https://issues.apache.org/jira/browse/AMQ-3411 | Admin commands which take --amqurl
should accept --user and --pass option |


Allen Reese
Core Platforms
Yahoo!, Inc.
 

> -----Original Message-----
> From: Joe Niski [mailto:joe.niski@nwea.org]
> Sent: Monday, September 19, 2011 1:45 PM
> To: users@activemq.apache.org
> Subject: "activemq-admin browse" and authentication
> 
> in ActiveMQ 5.4.2 and 5.5, it seems that there's no way to pass
> credentials to the "browse" command - i get an "unrecognized option"
> error when i try to add "--user" and "--password". Our broker requires
> authentication, so an administrative script i'm trying to write needs to
> authenticate (so i can act on a queue based on message content).
> 
> Looking at the source for both versions, i see two classes in
> org.apache.activemq.console.command - AmqBrowseCommand and
> BrowseCommand. AmqBrowseCommand doesn't take user & password params, but
> BrowseCommand does. It seems that activemq-admin is invoking
> AmqBrowseCommand (and, on the source trunk, i see that options for
> username and password have been added).
> 
> Is there a way to invoke BrowseCommand from the operating system shell
> in AMQ 5.4.2 and 5.5?
> --
> 
> *Joe Niski*
> Senior Developer - Information Services | NWEA(tm)
> 
> PHONE 503.548.5207 | FAX 503.639.7873
> 
> NWEA.ORG <http://www.nwea.org/> | Partnering to help all kids learn(tm)


Mime
View raw message