activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alistair Young <alistair.yo...@uhi.ac.uk>
Subject Re: Random persistent messages lost
Date Wed, 21 Sep 2011 08:15:09 GMT
> There was no producer, broker or connection crash while the msg was in transit?
no, the logs show it was up and sending

> The msg does not have an expiration time?

no

> Are you certain that no consumer has got the msg already?

yes, there's no record of it arriving at the consumer and no log of it in the kahadb data
store

the producer sent 49 messages in 2 seconds.The 43rd and 46th messages disappeared. They never
reached the broker it would seem.

------------------------------------
Alistair Young
Àrd-Innleadair air Bathar-Bog
UHI@Sabhal Mòr Ostaig




On 20 Sep 2011, at 15:50, Torsten Mielke wrote:

> There was no producer, broker or connection crash while the msg was in transit? 
> The msg does not have an expiration time?
> Are you certain that no consumer has got the msg already?
> 
> You could turn on full logging inside the broker, it will log each msgs being received.
Might not be suitable for a production system that deals with a higher load of msgs.
> 
> 
> Torsten Mielke
> torsten@fusesource.com
> tmielke@blogspot.com
> 
> 
> On Sep 20, 2011, at 12:18 PM, Alistair Young wrote:
> 
>> Is there anything that might cause a message to go missing? A producer sends a persistent
message to a topic but now and then, although no error is returned from the broker, the message
just disappears. It's not logged in the data store and it's as if it never reached the broker
but that would have produced an error for the producer to catch.
>> 
>> thanks,
>> 
>> Alistair
>> 
>> -- 
>> mov eax,1
>> mov ebx,0
>> int 80h
>> 
>> 
>> 
>> 
> 
> 
> 


Mime
View raw message