activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RickSnz <ricardo.s...@altran.es>
Subject Re: Failover reconnection questions
Date Thu, 22 Sep 2011 10:10:14 GMT
Any idea on this problem? What i wrote about the 10 seconds made me look for
configuration parameters that are 10000 ms by default, and i found
maxInactivityDurationInitalDelay. I've tried changing it in the consumer
uri:


failover://(tcp://host1:61616?wireFormat.maxInactivityDurationInitalDelay=99999,tcp://host2:61616?wireFormat.maxInactivityDurationInitalDelay=99999)

But it seems it must be changed in the broker too, because i get this output
(only information related to this problem):

2011-09-22 11:38:06,855 DEBUG o.a.a.t.WireFormatNegotiator
[WireFormatNegotiator.java:82] Sending: WireFormatInfo { version=7,
properties={CacheSize=1024, CacheEnabled=true, SizePrefixDisabled=false,
MaxInactivityDurationInitalDelay=99999, TcpNoDelayEnabled=true,
MaxInactivityDuration=30000, TightEncodingEnabled=true,
StackTraceEnabled=true}, magic=[A,c,t,i,v,e,M,Q]}
2011-09-22 11:38:06,917 DEBUG o.a.a.t.InactivityMonitor
[InactivityMonitor.java:331] Using min of local: WireFormatInfo { version=7,
properties={CacheSize=1024, CacheEnabled=true, SizePrefixDisabled=false,
MaxInactivityDurationInitalDelay=99999, TcpNoDelayEnabled=true,
MaxInactivityDuration=30000, TightEncodingEnabled=true,
StackTraceEnabled=true}, magic=[A,c,t,i,v,e,M,Q]} and remote: WireFormatInfo
{ version=7, properties={CacheSize=1024, CacheEnabled=true,
SizePrefixDisabled=false, MaxInactivityDurationInitalDelay=10000,
TcpNoDelayEnabled=true, MaxInactivityDuration=30000,
TightEncodingEnabled=true, StackTraceEnabled=true}, magic=[A,c,t,i,v,e,M,Q]}
2011-09-22 11:38:06,917 DEBUG o.a.a.t.WireFormatNegotiator
[WireFormatNegotiator.java:118] Received WireFormat: WireFormatInfo {
version=7, properties={CacheSize=1024, CacheEnabled=true,
SizePrefixDisabled=false, MaxInactivityDurationInitalDelay=10000,
TcpNoDelayEnabled=true, MaxInactivityDuration=30000,
TightEncodingEnabled=true, StackTraceEnabled=true}, magic=[A,c,t,i,v,e,M,Q]}
2011-09-22 11:38:06,917 DEBUG o.a.a.t.WireFormatNegotiator
[WireFormatNegotiator.java:125] tcp://host1/10.95.177.237:61617 before
negotiation: OpenWireFormat{version=7, cacheEnabled=false,
stackTraceEnabled=false, tightEncodingEnabled=false,
sizePrefixDisabled=false}
2011-09-22 11:38:06,917 DEBUG o.a.a.t.WireFormatNegotiator
[WireFormatNegotiator.java:140] tcp://host1/10.95.177.237:61617 after
negotiation: OpenWireFormat{version=7, cacheEnabled=true,
stackTraceEnabled=true, tightEncodingEnabled=true, sizePrefixDisabled=false}

I would apreciate any help on this, i'm completely stuck if i cant get
failover to work properly. At least help changing this parameter to see if
it's actually my problem.

--
View this message in context: http://activemq.2283324.n4.nabble.com/Failover-reconnection-questions-tp3826592p3832930.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message