activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kaustubh khasnis <kaustubh.khas...@gmail.com>
Subject Re: Slow producers
Date Sat, 06 Aug 2011 02:04:21 GMT
Hi,
Can anyone please help me with this??

--Kaustubh

On Fri, Aug 5, 2011 at 9:56 AM, kaustubh khasnis <kaustubh.khasnis@gmail.com
> wrote:

> forgot to mention, the numbers are in nanoseconds
>
> --Kaustubh
>
>
> On Fri, Aug 5, 2011 at 9:40 AM, kaustubh khasnis <
> kaustubh.khasnis@gmail.com> wrote:
>
>> Hi,
>> I have disabled flow control at the broker end. also I am sending messages
>> asynchronously, while the delivery mode is persistent. but still I am seeing
>> many spikes at the producer end in time required for send call.
>> Can anyone please help me with why this might be happening and what I
>> might be doing wrong??
>>
>> sample log for producer:
>> time to send 63000
>> time to send 63000
>> time to send 62000
>> time to send 63000
>> time to send 63000
>> time to send 63000
>> time to send 69000
>> time to send 62000
>> time to send 63000
>> time to send 63000
>> time to send 38030000
>> time to send 74000
>> time to send 72000
>> time to send 62000
>> time to send 62000
>> time to send 12740000
>> time to send 77000
>> time to send 63000
>> time to send 63000
>> time to send 66000
>> time to send 978000
>> time to send 71000
>> time to send 64000
>> time to send 73000
>> time to send 63000
>> time to send 634000
>> time to send 64000
>> time to send 78000
>>
>>
>> destinationpolicy at broker.xml:
>> <destinationPolicy>
>>     <policyMap>
>>       <policyEntries>
>>         <policyEntry topic=">" topicPrefetch="0"
>> producerFlowControl="false" memoryLimit="15mb"/>
>>       </policyEntries>
>>     </policyMap>
>>   </destinationPolicy>
>> <persistenceAdapter>
>>
>> Thanks and regards
>> Kaustubh
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message